Elonex One T & One T+, CnM Minibook > Beginners Board

Locked at White Screen on a Pineapple MPC7E1

(1/3) > >>

KanedaFr:
Hi all,


My LLL is a PineApple MPC7E1-001
Pictures are available here:





Its manual is available here

It was perfectly working when I bought it on ebay.
I mainly used it to read PDF on the train.
One day, it just stopped to work anymore and, since now, is stucked on the white screen (pic 1)
The only way to power it off is to way for empy battery (reset button doesn't work : it reboots and... hangs)

First thanks for all the posts I read here these last months, I learnt a lot...

Second, after reading all these posts, I was finally ready to get back to my little pc and try to revive it.

So, this is a list of everything I tried w/o success, still stuck on the white screen

10 sec on the small 'reset' button on the back
F2 hold + power
power + quicky F2
F3 hold + power
power + quicky F3

with OneT recovery stuff (uImage + recoveryxxx.rec) on a Fat16 SD
LeftShit + Fn + F1 hold + power
LeftShit + Fn + Left Control + power

with epc700 recovery stuff (minifs.img + recoverxx.img) on a Fat16 SD
LeftShit + Fn hold + power
LeftShit + Fn + Left Control + power
LeftShit + Fn + F1 hold + power
LeftShit + Fn + Right Control + power

Did try with 2.6 kernel based update to avoid more problems !

it seems I tried every key combo known to work on a system or another.
I never saw something else than this white screen while testing all these keys

so, unfortunatly, it's my turn to ask for advice on how to unlock/unbrick this LLL ....

I read it was possible to check root process using serial....
Do you think it will work if I use some USBSerial stuff like this one ?
I didn't open it yet but, before I do this, I would like to know if it's the last hope !

Thanks for any help

William

wicknix:
Well from the looks of it i don't think its *that* bad since your bootloader seems to be still intact (pic 1 shows boot logo). Usually if the machine is bricked you will get a blank white screen with rainbow colored lines running up and down the screen.

Have you tried booting an OS from a SD card yet? If not try this:

Download http://filefactory.com/file/ca774a0/n/3MX-Ultra3-2.6kernel-rootfs.tar.bz2

Partition and format an SD card with the first partition being fat16/fat32 and 16mb in size.
Second partition should be ext2 and at least 600mb. (or the rest of the cards free space)
Extract the rootfs to the second ext2 partition (as root user)
Then copy the kernel (uImage) from /boot to the fat16 partition.

To boot from SD card:
Hold FN+LeftShift, power on, (while still holding both those keys) now quickly hold F2 (thats 3 keys pressed and held) until you see X11 start.

With any luck it will work. From there you can mount the internal NAND and try to fix whatever is causing the machine to hang.

Cheers.

KanedaFr:
Hi,

thanks for the reply.

I didn't try 2.6 based boot, since I read it could erase the NAND w/o possibility to get back.

There is something I didn't undertand well really every post about SD boot : if there is a problem on the NAND, is this possibility (load uImage from SD) still available ?

I already tried to download 3MX for 2.6 without succes : link is broken.
If someone could temporay share it, I'll be happy to host it.

thanks again

T_Nut:
Hi
Well you have tried all key's and non work !! silly question time is your keyboard connected the ribbon cable has not worked loose. here's a link so you can see keyboard IMG_0803 http://projects.kwaak.net/twiki/bin/view/Epc700/InternalPics
Many Thanks
Andrew

KanedaFr:
Well...it could be the reason ... but caps lock & num lock work (led light on/off)
And I successfully rebooted/bugged it 2 or 3 times using Ctr+Alt+suppr (yes..THIS key combo makes the epc to reboot when it hangs)

Navigation

[0] Message Index

[#] Next page

Go to full version