Author Topic: bad eraseblocks and booting from sd card  (Read 2694 times)

vikingali

  • Newbie
  • *
  • Posts: 21
bad eraseblocks and booting from sd card
« on: May 28, 2011, 08:24:36 PM »
Hello was wondering if any could help me as new to linux and these little laptops.Started using this elonex onet+ as it was too difficult for my daughter to use.Anyway downloaded 3mx ultra with 2.6 kernel which is fantastic.
My problems are the Kernel loaded ok (I think) as I only need to hold F2 to get it to boot up.But I have loads of bad eraseblocks started to come up and cant load the os to nand,is there anyway to clear the bad block table as i think it must have been something I did as this computer hasn't had much use?
Also if I can't sort this is there anyway to make it boot automatically from the SD card?
How do I make the keyboard load automatically as a UK one when running on SD card?
(I have a 4GB SD card with the first partion as a FAT partion which I use as extra storage and a second partion EXT2 with 3mx operating on it.)
Thanks
Ali

T_Nut

  • Full Member
  • ***
  • Posts: 103
Re: bad eraseblocks and booting from sd card
« Reply #1 on: May 29, 2011, 06:55:16 PM »
Hi
Well it sounds like your nand is dying from what i have read on this forum.
you have to use keys to boot from sd card all the time.
on the plus side you can still use your one-t.
Many Thanks
Andrew
A linux Newbie. unemployed and getting bored

vikingali

  • Newbie
  • *
  • Posts: 21
Re: bad eraseblocks and booting from sd card
« Reply #2 on: May 29, 2011, 07:34:27 PM »
Thanks for replying thats what I thought but is there not a way to reset the place that it stores where it knows the blocks are bad or does it just do a fresh search each time it is turned on.
Also is there a way to store the keyboard map so it automatically boots up to a uk keyboard (I tried what it said in the help file for 3mx but that doesn't seem to work, I think it must be because it is running from the SD card). I can get the keyboard to work  if I type in "xmodmap /share/xmodmap/xmodmap.uk" in the terminal or run box, but can't figure out how to get it to do it automatically. ???

wicknix

  • Hero Member
  • *****
  • Posts: 634
Re: bad eraseblocks and booting from sd card
« Reply #3 on: May 30, 2011, 07:05:17 PM »
Unfortunately if you have too many bad blocks it slowly starts making the available free space on nand shrink. You might not have enough *good* available space left to install 3MX to nand. I don't think anybody has found a way to fix this. :(
You could always try to mount nand1 and rm -rf all the files on it and try to install 3mx again. It may or may not work.

As for the keymap issue. You could try this. It should work.
Open /etc/jwm/jwmrc in an editor and right near the top you'll see:
<StartupCommand> and under it 2 lines that start up the sound server.
Add xmodmap /share/xmodmap/xmodmap.uk to the next line and save.

So it looks like this:

<StartupCommand>
esd -nobeeps -as 10
esdplay /share/sound/startup.wav
xmodmap /share/xmodmap/xmodmap.uk
</StartupCommand>

Cheers

vikingali

  • Newbie
  • *
  • Posts: 21
Re: bad eraseblocks and booting from sd card
« Reply #4 on: May 31, 2011, 02:36:06 PM »
Thanks Wicknix,
That works for the keyboard :)
Looks like I must have broke the nand but I can live with it working from the SD card.
What is the largest size of SD card I can use and is it worth putting a 3rd partion on it as a swap partion ?
Ali

wicknix

  • Hero Member
  • *****
  • Posts: 634
Re: bad eraseblocks and booting from sd card
« Reply #5 on: June 01, 2011, 01:32:16 AM »
I haven't tested anything over 4gb, but 8gb and 16gb *should* work fine. Swap really isn't needed unless you like having more than 3 tabs open in firefox at a time, or are using a bunch of applications at once. Rather than making a swap partition i'd suggest creating a small (64-128mb) swapfile. Toss it into /opt and add
Code: [Select]
swapon /opt/swapfile to /etc/init.d/start (add the line after the keymap line but before the 2 lines about udev and dbus-launch). This will make your swapfile enabled at boot.

Cheers