Author Topic: help with WPA/WPA2 on etch/sid/lenny  (Read 2489 times)

rkdavis

  • Newbie
  • *
  • Posts: 16
help with WPA/WPA2 on etch/sid/lenny
« on: January 16, 2011, 07:21:37 PM »
hi,

connecting to my WPA2 router works fine in 3mx but i can't get it working for anything but open (not tried wep) in etch, lenny or sid. i've upgraded  wpa_supplicant and rebuilt wireless tools and still no joy. i've tried the wifi-config script plus a version of one i use successfully on another device and nada. i have edited the scripts to use eth2 so it's not that and i get lots of error messages about ioctl's using wpa_supplicant and lots of SoftMAC messages.

anyone got any ideas as i need WPA/WPA2 to be able to use my alpha400. 3mx would be fine as sound is working and well wifi does work but i'd prefer to use a rootfs on an sd card as i'm loathed to be writing to the internal nand all the time as i am currently doing in 3mx.

if i can't get wpa/wpa2 working in etch/lenny/sid does anyone know if i can run (and how to) 3mx from the sd card or make the sd card be the user writable partitions and leave the internal nand as readonly.

Thanks
Russell

T_Nut

  • Full Member
  • ***
  • Posts: 103
Re: help with WPA/WPA2 on etch/sid/lenny
« Reply #1 on: January 16, 2011, 08:22:52 PM »
Hi
I haven't tried wpa2 but i had problems in etch, sid i found sid a little unstable for me i got wep working in lenny
after editing scripts for eth2. at the moment iam runnig lenny of sd card and it's fine.stick with lenny alot better.
yes i have thought about running 3mx of sd card as well but don't know how to either sorry
Many Thanks
Andrew
A linux Newbie. unemployed and getting bored

rkdavis

  • Newbie
  • *
  • Posts: 16
Re: help with WPA/WPA2 on etch/sid/lenny
« Reply #2 on: January 18, 2011, 01:59:49 PM »
i've solved my wpa/wpa2 problem in etch and hopefully the same process will work in lenny/sid, it shoudl do as it's just killing a few things and setting up wifi in a specific way although the version of dhclient gives some horrible errors initially but if i don't get them then wpa/wpa2 doesn't work so i sit with crossed fingers waiting for the errors :) when setting up wifi.

but now my mipsbook (i use it on several devices rather than using GUI tools or doing it by hand) version of my easy wifi configurator script (both the dialog and cli versions) works :)

Russell

rkdavis

  • Newbie
  • *
  • Posts: 16
Re: help with WPA/WPA2 on etch/sid/lenny
« Reply #3 on: January 19, 2011, 04:02:01 AM »
nope still no joy using wpa/wpa2 in lenny. this is really driving me nuts

Robin

  • Newbie
  • *
  • Posts: 13
Re: help with WPA/WPA2 on etch/sid/lenny
« Reply #4 on: February 07, 2011, 10:25:42 PM »
I too, could not get WPA/WPA2 to work, but I turned my router down to WPA - that works. Then up to WPA2 - that works too, but WPA/WPA2 won't go! Lenny on SD card.