Author Topic: Stopping wifi from firing up  (Read 5397 times)

Unhban

  • Sr. Member
  • ****
  • Posts: 322
  • Thinks....
Stopping wifi from firing up
« on: May 01, 2010, 03:13:43 PM »
Hi Guys. I've leant my LLL to a friend for a while but he won't be using the wifi, just an attached 3 dongle.

To save battery can anyone say which file I should alter so that during boot-up the wifi doesn't fire up?

Unh.

Tank

  • Newbie
  • *
  • Posts: 8
Re: Stopping wifi from firing up
« Reply #1 on: May 01, 2010, 04:27:24 PM »
Hi Unh
Can't help you with the wiFi but wondered if you might be able to help me. I have been trying to connect my LLL using a 3G dongle but have been unable to do this. I have asked the question on this board and have tried all suggestions but still no luck. I have an Elonex oneT and 3mxUltra running on it. I am a real wrinkly novice at this but love this site and this OS that Wicknix has produced, any help would be appreciated, thanks
Alan

FezzFest

  • Jr. Member
  • **
  • Posts: 87
Re: Stopping wifi from firing up
« Reply #2 on: May 02, 2010, 09:39:43 AM »
@Unhban:

Do you have the model with WiFi build-in or with a WiFi USB-dongle? I case you have build-in WiFi, there is an option to turn it off in 3MX Ultra, in case you have an USB-dongle I think you know the solution too ;)

@Tank:

What chipset/type/model is your 3G dongle? If there's a driver available in 3MX it should work with some tweaks.

Unhban

  • Sr. Member
  • ****
  • Posts: 322
  • Thinks....
Re: Stopping wifi from firing up
« Reply #3 on: May 02, 2010, 10:22:07 AM »
Hi FezzFest, my Wifi is built in to the LLL and it's the original OS on the machine. My friend's a technophobe and preferred the original software - we did try others!

And hi to Tank. The mobile dongle I'm using is a Huawei E220. This works out of the box with the LLL as the LLL has the correct driver in the firmware. I specifically researched which dongle would work out of the box. The E220 is very popular and I got it off Ebay.

http://en.wikipedia.org/wiki/Huawei_E220

There are only two manufacturers of mobile dongles - Huawei and ZTE. In my research many have had problems getting ZTE dongles to work owing to the lack of drivers for them - in the Linux domain that is. The driver for the E220 is something like zo2260 which as I say is in the LLL firmware.

I use telecom company 3 which on PAYG gives 1GB for £10 or 3GB for £15. There may be cheaper packages but my mate, who uses the LLL at the mo, with his roaming circumstances prefers using it this way. Have a look here for how to connect to the 3 network:

http://linuxlaptopforum.ark2webdesign.co.uk/index.php/topic,581.0.html

My advice? Bite the bullet and buy an E220 that is unlocked. There are two versions: one with max.speed 3.6MHz and one with updated firmware to give 7.2MHz max.speed - I have the latter. I think it'd be worth it just to save a lot of hassle!

Hope this helps.

Unh.
« Last Edit: May 02, 2010, 10:28:42 AM by Unhban »

Tank

  • Newbie
  • *
  • Posts: 8
Re: Stopping wifi from firing up
« Reply #4 on: May 02, 2010, 11:03:24 AM »
Hi FezzFest
That was quick, thanks. Model is E1550 HSDPA USB Stick.
Alan

Tank

  • Newbie
  • *
  • Posts: 8
Re: Stopping wifi from firing up
« Reply #5 on: May 02, 2010, 11:11:37 AM »
Hi Unhban
Thanks for quick reply and for suggestions which I will lookat, I seem to havee a Huawei Model E1550 HSDPA USB Stick so I quess it is possible that it needs an updated driver on my machine so will lok at that also, thanks again
Alan

FezzFest

  • Jr. Member
  • **
  • Posts: 87
Re: Stopping wifi from firing up
« Reply #6 on: May 02, 2010, 11:38:13 AM »
@Uhnban:

Make sure you have the option to switch to command line or have installed XTerm. Execute this command:

echo 0 > /proc/jz/iwifi

In 3MX, that's the way to turn WiFi off.


Unhban

  • Sr. Member
  • ****
  • Posts: 322
  • Thinks....
Re: Stopping wifi from firing up
« Reply #7 on: May 02, 2010, 03:10:58 PM »
Cheers. Have XTERM loaded, a bit of knowledge of Linux, but to me the LLL seems to have random locations for files, that's why I asked  ;D

Will try that on the original OS or if it doesn't work, it's a starting point! ;)

Unh.

Unhban

  • Sr. Member
  • ****
  • Posts: 322
  • Thinks....
Re: Stopping wifi from firing up
« Reply #8 on: May 02, 2010, 03:19:42 PM »
@Tank. Have you tried plugging the modem into a Windows machine first? Just see if it works on that.

I've read in the past that some modems need to be plugged into a Windows machine first as they have software within them that reacts with Windows to sort of boot up the modem initially (or something - trying to remember what I read!). I did that with my E220 before anything else.

I guess we're a bit off topic talking about this here, so could you find a new thread or one already on the go and then post here where you'd like to continue the discussion? Ta.

Unh.

FezzFest

  • Jr. Member
  • **
  • Posts: 87
Re: Stopping wifi from firing up
« Reply #9 on: May 02, 2010, 05:09:28 PM »
Cheers. Have XTERM loaded, a bit of knowledge of Linux, but to me the LLL seems to have random locations for files, that's why I asked  ;D

Will try that on the original OS or if it doesn't work, it's a starting point! ;)

Unh.


Yeah, the default OS is weird stuff. It works, but I think even the creators don't really know how they got it working. :P
But the command should work on the default OS too.

Tank

  • Newbie
  • *
  • Posts: 8
Re: Stopping wifi from firing up
« Reply #10 on: May 03, 2010, 08:36:49 AM »
Hi Unhban
I have the dongle working on the laptop running Vista and it works fine, still trying with the LLL thanks for your help and yes this should not be here so will switch over, thanks again and when I do get it working I will let you know.
Alan

Unhban

  • Sr. Member
  • ****
  • Posts: 322
  • Thinks....
Re: Stopping wifi from firing up
« Reply #11 on: May 05, 2010, 01:05:35 PM »
@Uhnban:

Make sure you have the option to switch to command line or have installed XTerm. Execute this command:

echo 0 > /proc/jz/iwifi

In 3MX, that's the way to turn WiFi off.

Hi FezzFest. Pity, tried this today on the original OS but didn't work.....

Unh.

FezzFest

  • Jr. Member
  • **
  • Posts: 87
Re: Stopping wifi from firing up
« Reply #12 on: May 05, 2010, 08:01:53 PM »
In the TrendTac original OS, there is an icon to switch to eject WiFi. It's near the USB and Battery-icon.
Also, how did you try to see if it was disabled? Is there a LED or something similar on those models? Or have you used the WiFi utility? Because the last one automatically switches WiFi back on if it is disabled.
« Last Edit: May 05, 2010, 08:03:41 PM by FezzFest »

Hugh

  • Guest
Re: Stopping wifi from firing up
« Reply #13 on: May 05, 2010, 08:15:31 PM »
Am I being daft here but doesn't the wifi only turn on when you click on the icon to connect?
In 3MX Ultra the wifi section of the system monitor in the top right corner of the screen says 'no card' until you invoke wifi manually.

Cheers :)

Hugh

Unhban

  • Sr. Member
  • ****
  • Posts: 322
  • Thinks....
Re: Stopping wifi from firing up
« Reply #14 on: May 06, 2010, 11:15:30 AM »
On my Elonex OneT+ when I boot it up the wifi icon is at the bottom of the screen. If I click on it I can turn it off. So from that I presume it's on after booting up and sapping power even when not used. In the past, when I've had the Elonex at my home it's automatically connected to my adsl wifi router after boot up, so again that makes me think it's sapping power by trying to connect to a wifi hub when there isn't one around.

I don't want my mate to have to turn it off each time he boots up as he just wouldn't do it, yet want him to have as long a battery power as possible.  ;)