Elonex One T & One T+, CnM Minibook > Standard Software & Operating System

MTPaint

(1/2) > >>

Hugh:
Hello,

Recently joined here as I now have a miniBook.
I've gone back to the default OS as it seems to be quicker than 3MX (that's a shame and I feel guilty because of all the hard work put in), but the simplicity suits my needs and my eyes more.
Anyway, I tried installing MTPaint from the 3MX repos and of course it won't start from the icon.
In Terminal, /usr/bin/mtpaint gives an error about not finding libungif.so.4

Is there any way I can get the required library files from 3MX onto the system and make MTPaint work?

Cheers :)

Hugh

Hugh:
Is anybody willing to send me the following files from an 3MX installation? -

/usr/lib/libgif.so.4
/usr/lib/libgif.so.4.1.4
/usr/lib/libungif.so.4
/usr/lib/libungif.so.4.1.4
/usr/share/doc/libungif4g/NEWS.gz
/usr/share/doc/libungif4g/README
/usr/share/doc/libungif4g/UNCOMPRESSED_GIF.gz
/usr/share/doc/libungif4g/changelog.Debian.gz
/usr/share/doc/libungif4g/changelog.gz
/usr/share/doc/libungif4g/copyright
/usr/share/doc/libungif4g/gif89.txt.gz
/usr/share/doc/libungif4g/lzgif.txt.gz
/usr/share/lintian/overrides/libungif4g

the top four being the most important library files for MTPaint

It may not work, but I have recovery images of my whole system and am willing to take the risk of borking it.

Please PM me if you can help and I'll send an email address.

Many thanks,

Cheers :)

Hugh

Mijzelf:
You can easily extract them yourself. The 3mx.img file is just a .tar.gz file, which can be read by almost all popular archiver software.

Hugh:
Flippin' heck, I wish I'd thought of that :D

Thanks, will try later when I get home.

Cheers :)

Hugh

Hugh:
OK, copied files from Debian Etch recovery image, and first put them into proper place (/usr/lib).
Same error, so next I copied them to /lib
I then got the error 'error while loading shared libraries /opt/mipsel/mipsel-linux/lib/libungif.so.4: invalid ELF header
I checked the files and they are exactly the same ones (size / date the same)

It turns out, the library files had already been installed with MTPaint, in /opt/mipsel/.... , because they disappeared from that location when I uninstalled

Have given up as it's going beyond my scant knowledge of Linux and obviously not easily compatible

Cheers :)

Hugh

Navigation

[0] Message Index

[#] Next page

Go to full version