Author Topic: Recovery_DebianEtchX11-wicknix bugs  (Read 5170 times)

Unhban

  • Sr. Member
  • ****
  • Posts: 322
  • Thinks....
Recovery_DebianEtchX11-wicknix bugs
« on: June 10, 2009, 03:18:59 PM »
Seem to have a problem with Wifi. It's like the old 3MX v.2.0 where it seems nothing is going out to the wifi router once the Wireless LAN app. GUI has been configured. I get NOT CONNECT in WLAN app., signal strength is 92%. I'm using WPA2 which worked OK of course in 3MX v.1.1 and 3.1.....

iwconfig shows that eth1 has nothing for ESSID, but freq. is set OK and also Link Quality, Signal level and Bit rate.....

EDIT!: Just trying to work my way through this problem as a working wifi is most needed!  ;) Been going through some previous posts about the wifi side with Debian, and I see that there is no wpa_supplicant.conf file in /etc/wpa_supplicant/ which is used for WPA/WPA2 encryption.... as mentioned in reply #34 here:

http://linuxlaptopforum.ark2webdesign.co.uk/index.php/topic,599.30.html

So have created a blank /etc/wpa_supplicant/wpa_supplicant.conf  file.

This is ongoing work so just rebooting now and will modify this post further as things hopefully progress! But if you know the answer don't keep mum!

Unh.
« Last Edit: June 10, 2009, 04:10:32 PM by Unhban »

duttydea

  • Full Member
  • ***
  • Posts: 136
  • You wont know untill you search, then ask!!
Re: Recovery_DebianEtchX11-wicknix bugs
« Reply #1 on: June 10, 2009, 05:58:09 PM »
Backspace button not responding
I noticed this bug ?? i the original etch recovery image.

I have tried xev and get no response when pressing the backspace key!! ??? >:(

I will try an external kb and see what happens!!
______________________________________________
CnM MiniBook : 3MX RC3.1 / Custom Debian (DLA)
Desktop: XP PRO & Vista
Linux Knowledge: Restricted to 3MX & Debian Etch (Basic)

Unhban

  • Sr. Member
  • ****
  • Posts: 322
  • Thinks....
Re: Recovery_DebianEtchX11-wicknix bugs
« Reply #2 on: June 10, 2009, 06:09:49 PM »
Yes, after exploring the keyboard I've found for some strange reason it's all a bit 'all over the place'. The non-alphabetic or number keys e.g. £$% are not in the right places, and can't find a \ anywhere!  :o

Unh.
« Last Edit: June 10, 2009, 06:11:55 PM by Unhban »

duttydea

  • Full Member
  • ***
  • Posts: 136
  • You wont know untill you search, then ask!!
Re: Recovery_DebianEtchX11-wicknix bugs
« Reply #3 on: June 10, 2009, 06:31:43 PM »
xmodmap.uk taken from rc3.1
http://www.filefactory.com/file/ag5627d/n/xmodmap_uk

Use xmodmap -pke > /root/cnmxmodmap.uk to output your keymap file. compare & make any changes.
to test use xmodmap /root/cnmxmodmap.uk and test your keys

I have tried just using xmodmap.uk but it was even worse!!

Maybe it has something to do with the kb driver (unsure if there is a driver)


« Last Edit: June 10, 2009, 06:51:41 PM by duttydea »
______________________________________________
CnM MiniBook : 3MX RC3.1 / Custom Debian (DLA)
Desktop: XP PRO & Vista
Linux Knowledge: Restricted to 3MX & Debian Etch (Basic)

wicknix

  • Hero Member
  • *****
  • Posts: 634
Re: Recovery_DebianEtchX11-wicknix bugs
« Reply #4 on: June 10, 2009, 07:08:24 PM »
My 2 cents:

Wifi wasn't tested on anything but an open wireless network. Hopefully you all figure out WPA. You could use mewwto's wifi enable script which i've moved to /usr/local/bin

If you have a 3g usb dongle or cellphone you could try tethering also. The scripts are the same from rc3.1 and work fine with my samsumg blackjack2 to connect. Found in /etc/ppp/peers.

The keyboard and backspace key work fine on my alpha400. I'm wondering if it has something to do with changes to keyboards on overseas knock off units like the cnm and elonex machines.

Good luck.

Cheers.

Whiskers

  • Full Member
  • ***
  • Posts: 127
Re: Recovery_DebianEtchX11-wicknix bugs
« Reply #5 on: June 10, 2009, 07:18:31 PM »
I have no experience of the way Debian's package management and repository system works (and the naming of versions is totally opaque to me so I don't know which is older), but I /think/ "wicd" is available for the mipsel build of Etch, from the 'Lenny backports' repository.  <http://packages.debian.org/search?suite=all&arch=mipsel&searchon=names&keywords=wicd>.  Would that work better than the wireless GUI from the original operating system?  (Can it even be installed?  I confess I have not yet put Debian on the CnMbook - I'm learning about Arch Linux on another machine at the same time, and my brain hurts!).
CnMbook user since March 2009; Linux user since about 2003.

duttydea

  • Full Member
  • ***
  • Posts: 136
  • You wont know untill you search, then ask!!
Re: Recovery_DebianEtchX11-wicknix bugs
« Reply #6 on: June 10, 2009, 07:58:27 PM »
Wicd was not available under etch

Quote
apt-get install wicd
E:couldn't find package wicd

Maybe someone can compile it for us (I would try myself but I bricked my 3MX 3.1 last time I tried)?

EDIT: I followed the instructions on: http://packages.debian.org/lenny-backports/all/wicd/download & added lenny-backports to the repository

Did apt-get update (got the lenny-backports app list)
tried:
Quote
apt-get install wicd
Broken packages
It needs python-support 0.7.1 and above

Doing an
Quote
apt-get install python-support
downloads 0.5.6

@wicknix: Does Linux use a kernel module to load the keyboard? if so. is there a difference in the one used in 3MX /Default OS?

« Last Edit: June 10, 2009, 08:26:47 PM by duttydea »
______________________________________________
CnM MiniBook : 3MX RC3.1 / Custom Debian (DLA)
Desktop: XP PRO & Vista
Linux Knowledge: Restricted to 3MX & Debian Etch (Basic)

wicknix

  • Hero Member
  • *****
  • Posts: 634
Re: Recovery_DebianEtchX11-wicknix bugs
« Reply #7 on: June 11, 2009, 03:02:49 AM »
The kernel does have a generic keyboard driver built in (no module, but built right into the kernel). This gives you most of the keys functioning in console mode. The xmodmap files (from default OS and 3MX) only work once X11 (desktop) is up and running. Since i dont have the backspace issue i'm kind of useless in trying to figure out why it doesn't work on other knock off machines. I think debian/xorg uses xkbd however. You may try looking into that. Otherwise i haven't a clue.

Cheers.

Whiskers

  • Full Member
  • ***
  • Posts: 127
Re: Recovery_DebianEtchX11-wicknix bugs
« Reply #8 on: June 11, 2009, 01:59:01 PM »
Wicd was not available under etch

[...]

Did apt-get update (got the lenny-backports app list)
tried:
Quote
apt-get install wicd
Broken packages
It needs python-support 0.7.1 and above

Doing an
Quote
apt-get install python-support
downloads 0.5.6

[...]

Sadly, 'Lenny backports' doesn't seem to have python-support 0.7.1 which is a bit sad  :((  Perhaps someone will get around to adding it.  <http://www.debian.org/support> would be the place to start looking for help with that, I think.
CnMbook user since March 2009; Linux user since about 2003.

LilYoda

  • Newbie
  • *
  • Posts: 25
Re: Recovery_DebianEtchX11-wicknix bugs
« Reply #9 on: June 12, 2009, 08:17:28 PM »
Issues found so far.  I'll be editing this post as I move forward...

 - the wifi modules don't work on all hardware.  need to downgrade to the modules that were in 3MX v1.1
 - the sources.list links to a mirror missing stuff (it doesn't have the SSH server for exemple)
Here is the sources.list I have
Code: [Select]
deb http://ftp.debian.org/debian etch main contrib non-free
- still has the root directory wrong permissions.  Need to add this to /etc/rc.local
Code: [Select]
chmod a+x / - /dev/null is unwritable when you telnet to the machine. Need to add this to /etc/rc.local
Code: [Select]
cd /dev
MAKEDEV null
« Last Edit: June 12, 2009, 08:49:11 PM by LilYoda »