Author Topic: Getting Abiword to recognise en_GB as Locale on CnM  (Read 2207 times)

rodonn

  • Jr. Member
  • **
  • Posts: 73
Getting Abiword to recognise en_GB as Locale on CnM
« on: May 08, 2009, 08:55:47 AM »
These are the steps I made. I have no idea if any are redundant.

1) Overwrote /share/AbiSuite02.4/templates/normal.awt with normal.awt-en_GB
2) Overwrote /share/AbiSuite02.4/AbiWord/system.profile with system.profile-en-GB
3) Edited etc/init.d/locale.data to read en_GB.utf8
4) Created /etc/init.d/locale/en_GB. Copied /etc/init.d/locale/en_US/locale.data to new dir. Edited locale token in file to equal en_GB.utf8

After a reboot, the Abiword settings seem to be correct - Lang=en_GB, Paper=A4 Units=cm.
In xterm, if I type locale, I get a few warnings (I'll post a screen scrape from the CnM in a mo) but it generally looks correct.

rodonn

  • Jr. Member
  • **
  • Posts: 73
Re: Getting Abiword to recognise en_GB as Locale on CnM
« Reply #1 on: May 08, 2009, 09:20:44 AM »
NOTE: The above seems to work 99%. It's not finding the LC_MESSAGES files. I think I'm hitting my head against incomplete i18n support...