Author Topic: I THINK I'VE KILLED IT!!!  (Read 6243 times)

LUNARLIL

  • Guest
I THINK I'VE KILLED IT!!!
« on: April 13, 2009, 08:20:11 PM »
i got an elonex onet+ (from ebay so therefore no warranty) I tried to do a recovery which i got from the elonex website and now all i can get is the elonex screen.  i have tried the recovery again and resetting and have sent it to few techie friends but to no avail as they aren't up to date with linux if anyone has any ideas how to get this thing going again i would greatly appreciate it.

utd_grant

  • Guest
Re: I THINK I'VE KILLED IT!!!
« Reply #1 on: April 14, 2009, 08:29:56 AM »
The only things I can think of are:

1. Format a low-capacity (<4GB) SD card with the FAT file system.
2. Write the recovery files to the root directory of the SD card.
3. Try pressing F3 repeatedly as soon as you switch it on, until the recovery prompt appears.
4. Fully format the SSD and recover.

If it won't do this, then it sounds like you might unfortunately just have a dud machine. Sorry.  :(

G0AOZ

  • Guest
Re: I THINK I'VE KILLED IT!!!
« Reply #2 on: April 14, 2009, 10:30:53 AM »
Best advice from UTD_GRANT...

I've no idea if this will work, and I'm assuming here that the Cnm and Elonex motherboards are similar or identical.  (Can someone confirm?).  Remove the motherboard from the case and you'll probably find a CMOS battery on the underside.  Remove the battery and short out the battery connections on the motherboard.  This will help to bring down all the circuits to zero volts.  Now replace battery and rebuild.  Give it another whirl...

For a variety of reasons, the CMOS can get screwed up on motherboards of all sorts, and the above has sometimes sorted out problems, assuming nothing is actually damaged.  Oh, and you'll find the date and time needs resetting.

Good luck.

RDP

JamesDavid

  • Guest
Re: I THINK I'VE KILLED IT!!!
« Reply #3 on: April 16, 2009, 01:57:31 PM »
As already mentioned, it is critical that the SD card you use is formatted to the correct standard. My experience has been that cards bought e.g. for use with a camera are already formatted correctly. It needs to be large enough to hold the recovery files, but no larger than 4gb. An 8gb card won't work! Using your pc, copy the recovery file or files obtained from Elonex to the root directory of the card. No other files should be stored there. Insert the card into the minibook making quite sure it's the correct way round, which for mine was upside down, with contacts upppermost!!! Switch on the machine and immediately hold down F3 and keep it down. After a short while the recovery screen should appear. Only then release F3 and continue by following the prompts. Select the option to format the flash memory, when it appears. The recovery will take a few minutes and the machine should reboot to the desktop.

If no recovery screen appears after a minute of holding F3 then the machine may be bricked and should be returned to the seller for refund.

It is just possible that the kernal is corrupt... it may be worth trying to restore this first.

mewtwo

  • Guest
Re: I THINK I'VE KILLED IT!!!
« Reply #4 on: May 09, 2009, 03:33:55 AM »
Make sure to format the SD card using fat16, not fat32. Make sure that you have inserted the SD card the right way round. Do press f3 for a while, if you have screwed your uboot bootloader, if so, check out the wiki, there you also can get some backlight control.
But first, make sure thet you have inserted the fat16 formated SD card the right way, that there is a recovery image on it and that you have pressed f3 long enough

rodonn

  • Guest
Re: I THINK I'VE KILLED IT!!!
« Reply #5 on: May 09, 2009, 04:34:51 PM »
Have you tried the reset hole on the underside (unless that's a model change on my CnM)

gingergibbon

  • Guest
Re: I THINK I'VE KILLED IT!!!
« Reply #6 on: December 04, 2009, 01:45:34 PM »
The exact same thing has happened to mine, also bought from ebay so no warranty. spoke to elonex support to assist in getting wifi connected they sent me a link to download and install a recovery image which I put onto a fat 16 formatted sd card card, it didn't work but formatted the drive so now it has no operating system it just hangs on the boot up screen!!! tried different recovery images but after pressing enter to format and start the install get 3 white dots and then file or directory cannot be found system will now reboot...argghhhh tried upgrading the kernel but that does not work on the boot up screen it says elx v06, could I use an external dvd drive to install the os? how do you enter bios to boot from usb?

Leven2e

  • Guest
Re: I THINK I'VE KILLED IT!!!
« Reply #7 on: December 05, 2009, 12:16:56 AM »
no external optical drive can be used.

gingergibbon

  • Guest
Re: I THINK I'VE KILLED IT!!!
« Reply #8 on: December 05, 2009, 11:15:53 AM »
Hi is that No you can't use an external drive?

wicknix

  • Guest
Re: I THINK I'VE KILLED IT!!!
« Reply #9 on: December 05, 2009, 08:34:36 PM »
There is no bios. You can only use SD cards to reflash (or boot) the operating system. Once the OS is loaded you can then 'use' cdrom drives and usb thumb drives.

Cheers.

gingergibbon

  • Guest
Re: I THINK I'VE KILLED IT!!!
« Reply #10 on: December 06, 2009, 11:55:33 AM »
Hi thanks for response, when i put the rcovery image onto an sd card and press f3 to enter recovery menu It cant fine the file, but if I put it thrugh the usb port it does? it then begins the format and then say's file or directory not found syncing then elonex will reboot it then hangs on boot up screen. and nothing else happens.

wicknix

  • Guest
Re: I THINK I'VE KILLED IT!!!
« Reply #11 on: December 06, 2009, 06:13:22 PM »
The issue you are describing with USB updating sounds normal. That's what mine does. It starts and fails. Now why it doesn't work with SD card is the question. Are you sure the SD card is freshly formatted and inserted properly (meaning the SD card actually goes in upside down)?

Cheers.