Author Topic: Sending Email EHLO invalid  (Read 10001 times)

happytheman

  • Guest
Sending Email EHLO invalid
« on: March 19, 2009, 09:43:06 PM »
I'm using a CnM minibook and loving it, I'm writing this on it   ;D.  I can receive email but get an error message when sending.  It says 'syntactically invalid EHLO argument(s)'.

Has anyone else had this problem?

Pasted from log:

* Connecting to SMTP server: smtpmail.freenetname.co.uk ...
[21:39:00] SMTP< 220 smtp-proxy08.plus.net ESMTP Exim Thu, 19 Mar 2009 21:40:36 +0000
[21:39:00] SMTP> HELO (none)
[21:39:00] SMTP< 501 Syntactically invalid HELO argument(s)
« Last Edit: March 19, 2009, 09:46:59 PM by happytheman »

stefanie

  • Guest
Re: Sending Email EHLO invalid
« Reply #1 on: March 20, 2009, 07:57:33 AM »
maybe you should check your setting of send.

Mijzelf

  • Guest
Re: Sending Email EHLO invalid
« Reply #2 on: March 20, 2009, 09:05:48 AM »
EHLO is the command used to identify the client (the CnM) to the server. The syntax is
EHLO clientname
According to the log the CnM mailclient uses HELO (which is older) without or with (none) as clientname, which is rejected by the server.

You can try to give a valid clientname in the accountsettings (I suppose it will be 'Identify as' in 'Advanced' or something like that). Take a name without spaces or without weird characters. If that doesn't work, try what is behind "Hostname" on www.watismijnip.nl.

happytheman

  • Guest
Re: Sending Email EHLO invalid
« Reply #3 on: March 20, 2009, 09:06:18 AM »
All the settings are correct.  It is the configuration of sylpheed, HELO is the start of the handshake and sylpheed passes certain parameters to freenetname, it is these parameters that are missing.  I can't work out why.

Deliber8

  • Guest
Re: Sending Email EHLO invalid
« Reply #4 on: March 23, 2009, 08:32:44 PM »
Hi Happytheman

Go to the advanced tab in mail preferences.
Tick the port boxes.
Type freenetname.co.uk in the specify domain box.
Enjoy!

Deliber8

Whiskers

  • Guest
Re: Sending Email EHLO invalid
« Reply #5 on: March 23, 2009, 08:45:40 PM »
All the settings are correct.  It is the configuration of sylpheed, HELO is the start of the handshake and sylpheed passes certain parameters to freenetname, it is these parameters that are missing.  I can't work out why.
(This is my first post to these forums - so please be gentle if I'm breaching local customs or anything!)  Running the command 'hostname' on my CnMbook returns '(none)', which is what appears in the SMTP server's response to Sylpheed's HELO.  Normally, the 'hostname' of the machine is stored in a file /etc/hosts - but for some reason, the CnMbook has no such file; instead it has 'hostname' which is where the name I gave the machine in 'Settings - Network setup' is stored.

Just to see what happens, I created a file /etc/hosts and in it I put the usual basic information (all on one line)

127.0.0.1          shortname longname localhost

(There's a tab after the IP number; shortname and longname are the same if you only give the machine a one-word name such as mylll or you can have a longname such as mylll.is.black; localhost is the generic name all computers have for referring to themselves internally).

Now when I send an email, the SMTP server shows my computer's name instead of '(none)'.  That change seems to persist after a reboot too  :))

happytheman

  • Guest
Re: Sending Email EHLO invalid
« Reply #6 on: March 27, 2009, 10:25:04 AM »
Thanks for the responses, it turned out that I had to specify a domain name in the advanced settings configuration within sylpheed.  Went first time after specifying the reply-to address in send settings ;D

Andy
« Last Edit: March 27, 2009, 10:32:27 AM by happytheman »

Freddie43

  • Guest
Re: Sending Email EHLO invalid
« Reply #7 on: July 08, 2009, 07:15:56 PM »
Thanks for this thread. Setting the domain name in the advanced settings has at last enabled me to send emails via WiFi hotspots for one of my ISPs, but not Tiscali.

Has anyone managed to send via Tiscali at a WiFi hotspot?

happytheman - what do you mean by 'specifying the reply-to address in send settings' ?
- my Sylphspeed is 2.4.1 and doesn't seem to have this option in the 'Send' tab of 'Account preferences'
« Last Edit: July 09, 2009, 09:33:32 PM by Freddie »

Whiskers

  • Guest
Re: Sending Email EHLO invalid
« Reply #8 on: July 10, 2009, 03:09:20 PM »
Thanks for this thread. Setting the domain name in the advanced settings has at last enabled me to send emails via WiFi hotspots for one of my ISPs, but not Tiscali.

Has anyone managed to send via Tiscali at a WiFi hotspot?

[...]

See Tiscali 'Help':-
Quote
Are you connecting to the Internet through Tiscali?
If not, even if your mail settings are correct, you will not be able to send emails using a mail client, although you will be able to receive them. This is because the SMTP server which appears in your settings must be the same one as the ISP you are connecting through.

So if you want to send emails 'From' your Tiscali email address while you are not using your Tiscali internet connection, you will have to use an SMTP server that permits 'relaying'.  I have a 'premium' Yahoo account (actually my old BTInternet ISP account, converted to email-only) which allows relaying to be set up using their 'Options - Mail Accounts' settings.  Such services usually have to be paid for.

Freddie43

  • Guest
Re: Sending Email EHLO invalid
« Reply #9 on: July 10, 2009, 04:17:08 PM »
Hello again Whiskers!

Thanks for that - I hadn't spotted it - but it explains why I can send email via my Claranet account - that uses 'relay'.