Author Topic: Airodump-ng not working..  (Read 1984 times)

Felix

  • Guest
Airodump-ng not working..
« on: March 11, 2009, 02:02:04 PM »
I was playing around on the 3MX Rc2 distro and I noticed it has airodump-ng so thinking WoW! I can monitor wifi I tried to get it working but to no avail.

The output from airodump

ARP linktype is set to 1 (Ethernet) - expected ARPHRD_IEEE80211
or ARPHRD_IEEE80211_PRISM instead. Make sure RFMON is enabled:
run 'ifconfig wlan0 up; iwconfig wlan0 mode Monitor channel <#>'

So then I tried the command it advised ifconfig eth1 up; iwconfig eth1 mode Monitor

Then nothing, nada, zilch, not a bean..

So I thought maybe try airmon-ng start eth1

That just scrolls up and empty interface.. no device

So then I went digging around in /etc and found wireless.conf and used cat to get the output of the file.
which says:
iface eth1
MODE Ad-Hoc

So I tried to change those to
iface wlan0
MODE Monitor

But then when you restart the wifi scanner to bring the wifi card up the output of ifconfig -a
reveals it still see's the card as eth1 in Ad-Hoc mode...

Anyone know of a way to get this working?

Or is it a case of wait for 3MX Final :/
« Last Edit: March 11, 2009, 02:08:18 PM by Felix »