Small Linux Laptop Forum

Elonex One T & One T+, CnM Minibook => Networking => Topic started by: popski3125 on March 21, 2010, 07:33:01 AM

Title: WiFi Problems - Cannot find server/Invalid IP Address
Post by: popski3125 on March 21, 2010, 07:33:01 AM
After months of working with my Netgear router, I suddenly started having problems. There were two symptons, the first being that sometimes an Invalid IP Address was reported and when it did have a valid IP, Firefox would report 'Server Not Found'. Using a cable instead of wireless worked fine.

I am a professional programmer/engineer, so I tried the magic fix of turning everything off and on again. No luck.

At this point I had the OneT sitting about a foot from the router, and I noticed that not only was the signal strength changing by about 25%, another router was playing now you see me, now you don't  This smelt like cross-channel interference. My router was set to channel 5 and changing to channel 6 made it work better - not a total fix, but clearly on the right lines. Changing to channel 3 fixed it. Why 3? Just a guess.

I had, over the previous couple of days noticed that my Vista laptop sometimes took a long time connecting and had had some problems doing file transfers, so I suspect that the problem was not limitted to the OneT.

My theory is that the whole problem revolves around the retry/timeout mechaniism in the OneT, but I was suprised that the router did not seem to have any way of detecting this sort of interference.

Hope this helps others....